Page 1 of 1

Error Installing PHP 5.4 + APPSEC-212 Patches on v1.8.1.0. N

PostPosted: Fri Jan 24, 2014 10:10 am
by msjpt
Hi,

Im using Magento Community v1.8.1.0 on a Linux server, and i try to apply the 2 patches available at: http://www.magentocommerce.com/download

One patch is for PHP 5.4 support and the other is to fix some security problems.

My Magento is running on a subdomain and i have according to the instructions, upload using FTP both patches to the root of my Magento installation and then using SSH Root i have run the following 2 commands:

sh PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh

sh PATCH_SUPEE-2619_EE_1.13.1.0_v1.sh

After run the 2 commands, instead of getting the sucess message: “Patch was applied/reverted successfully.” i have received the following errors on both commands:

---------------

root@cpXX [/home/XXXXX/public_html/v1]# sh ./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh
./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh: line 2: syntax error near unexpected token `(’
./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh: line 2: `<!-- saved from url=(0097)http://www.magentocommerce.com/index.php/getmagento/ce_patches/PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh -->’

root@cpXX [/home/XXXXX/public_html/v1]# sh ./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh
./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh: line 2: syntax error near unexpected token `(’
./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh: line 2: `<!-- saved from url=(0097)http://www.magentocommerce.com/index.php/getmagento/ce_patches/PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh -->’

---------------

root@XX [/home/XXXXX/public_html/v1]# sh ./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh
./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh: line 2: syntax error near unexpected token `(’
./PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh: line 2: `<!-- saved from url=(0097)http://www.magentocommerce.com/index.php/getmagento/ce_patches/PATCH_SUPEE-2747_EE_1.13.1.0_v1.sh -->’

root@XX [/home/XXXXX/public_html/v1]# sh PATCH_SUPEE-2619_EE_1.13.1.0_v1.sh
PATCH_SUPEE-2619_EE_1.13.1.0_v1.sh: line 2: syntax error near unexpected token `(’
PATCH_SUPEE-2619_EE_1.13.1.0_v1.sh: line 2: `<!-- saved from url=(0097)http://www.magentocommerce.com/index.php/getmagento/ce_patches/PATCH_SUPEE-2619_EE_1.13.1.0_v1.sh -->’

--------------

Can someone please help me on this? How can i resolve this problem in order for the 2 patches to be installed properly?

Thanks

Re: Error Installing PHP 5.4 + APPSEC-212 Patches on v1.8.1.

PostPosted: Wed Jan 29, 2014 10:05 am
by edmondscommerce
How did you download the patches?

Re: Error Installing PHP 5.4 + APPSEC-212 Patches on v1.8.1.

PostPosted: Wed Jan 29, 2014 10:15 am
by msjpt
edmondscommerce wrote:How did you download the patches?


Hi edmondscommerce,

As you can read on my message i still did not have been able to install the 2 patches. It keeps giving me the error.

Do you have any ideas or advices?

Thanks