Magento Forum - UK Magento Forum (Unofficial)

An unofficial but dedicated Magento Forum for Magento Users, Designers and Developers

Widgets and widget instances not working

A forum for web designers working with the Magento system.

Widgets and widget instances not working

Postby wardworth » Tue Aug 24, 2010 2:41 pm

Has anybody tried using the built in widgets in Magento? I've tried using both the 'insert widget' and 'widget instances' features to display new products - Catalog New Products List - but they just wont display. Refreshed the cache, checked I've selected the right template etc etc but with no luck. I know that my static block is accepting what I'm putting in as it will display images, text etc, but widgets (or the Catalog New Products List one, at least) just wont display.

Any ideas?

UPDATE - okay I've got new products to display. You have to set the new product date on the product page in admin. The new product widget isn't that brilliant though as it will show all new products in every category. It doesn't restrict the view to new products from the category you are in. Anyone any idea how this can be done?
Ste
Wardworth Ltd
Magento 1.5.1.0
wardworth
 
Posts: 54
Joined: Mon May 24, 2010 2:32 pm

Re: Widgets and widget instances not working

Postby edmondscommerce » Wed Aug 25, 2010 4:00 pm

Have yet to mess with widgets much..

can't imagine that would be too hard though...

presumably you would need to make a custom widget based upon the standard new products widget, but adjusted to only look in a specific category
User avatar
edmondscommerce
 
Posts: 1157
Joined: Fri Sep 11, 2009 8:55 am
Location: UK

Re: Widgets and widget instances not working

Postby wardworth » Thu Aug 26, 2010 10:13 am

Any idea how I'd do this? Not even sure where to start...
Ste
Wardworth Ltd
Magento 1.5.1.0
wardworth
 
Posts: 54
Joined: Mon May 24, 2010 2:32 pm



Return to Magento Designers

cron